Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Panorama Community. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Tom58

Super-User

  • »Tom58« ist der Autor dieses Themas

Beiträge: 246

Wohnort: Südliches Rhein-Main-Gebiet

  • Nachricht senden

1

Samstag, 12. Januar 2019, 11:59

Motivabhängige Stitchingfehler bei PTgui?

Hallo zusammen,

nach vielen Monaten Feintuning wage ich jetzt die Behauptung, mein NPA ist im 99% Bereich Korrekt eingestellt. Keine Parallaxeverschiebung bis zum äußersten Bildrand des Suchers - so soll es sein!

So zeigen sich bei den 'normalen' Aufnahmen auch tatsächlich keine Stitichingfehler mehr. Allerdings kam mir die Woche ein Motiv unter, welches ich jetzt als für PTGui perfekt angesehen habe. Viele Möglichkeiten für CPs -- und so machte ich mich froh (und gewissenhaft!) ans Werk. Nach dem Stitching in PTgui dann die Ernüchterung. Stitchingfehler ohne Ende (bestimmt 7-10 Stück) und nicht die geringste Erklärung dafür!

Das (leidlich in PS korrigierte) Foto habe ich jetzt einmal als 2D-Version beigefügt, auf Wunsch kann ich das auch in Roundme hoch laden.

Bei einem - meiner Meinung nach - wesentlich schwierigeren Motiv am gleichen Tag: 0 Stichingfehler!

Hat jemand eine Erklärung für dieses Phänomen? Ich dachte immer, PTgui hat nur mit einheitlichen Flächen Probleme, nicht aber mit so einem Feuerwerk an möglichen Kontrollpunkten. Aber irgend etwas hat die Software verwirrt und mir fällt nichts ein.

Danke und Gruß

Tom
»Tom58« hat folgende Datei angehängt:

Undertable

Mega-User

Beiträge: 1 117

Wohnort: all over the world

Beruf: Imperator

  • Nachricht senden

2

Samstag, 12. Januar 2019, 16:22

Möglicherweise liegt die Schwierigkeit darin begründet dass sich Dein Feuerwerk der möglichen Kontrollpunkte auf z.T. sehr unterschiedlichen Entfernungen abspielt.
Da gilt es dann aus dem Feuerwerk CPs so zu löschen dass solche vom Programm verarbeitet werden die eben möglichst in der selben Ebene liegen.
Vielleicht spielen Dir auch harte Schatten vom Sonnenlicht einenen Streich?

3

Samstag, 12. Januar 2019, 20:46

Das lässt sich ja sehr leicht feststellen indem du die Liste der Kontrollpunkte analysierst.
Manchmal ist es nur ein einziger, den ptgui falsch platziert und der dann alles durcheinander bringt.
Es soll auch schon vorgekommen sein, dass Leute an ihr Stativ gerumpelt sind.
Die helle Deckenfläche ist ebenfalls ein möglicher Quell für Fehler.

Tom58

Super-User

  • »Tom58« ist der Autor dieses Themas

Beiträge: 246

Wohnort: Südliches Rhein-Main-Gebiet

  • Nachricht senden

4

Sonntag, 13. Januar 2019, 13:35

Möglicherweise liegt die Schwierigkeit darin begründet dass sich Dein Feuerwerk der möglichen Kontrollpunkte auf z.T. sehr unterschiedlichen Entfernungen abspielt.
Da gilt es dann aus dem Feuerwerk CPs so zu löschen dass solche vom Programm verarbeitet werden die eben möglichst in der selben Ebene liegen.
Vielleicht spielen Dir auch harte Schatten vom Sonnenlicht einenen Streich?


Hallo Oli,

also grundsätzlich spielt das Motiv schon eine Rolle? So jedenfalls interpretiere ich Deine Hinweise.

Gruß

Tom

Tom58

Super-User

  • »Tom58« ist der Autor dieses Themas

Beiträge: 246

Wohnort: Südliches Rhein-Main-Gebiet

  • Nachricht senden

5

Sonntag, 13. Januar 2019, 13:40

Das lässt sich ja sehr leicht feststellen indem du die Liste der Kontrollpunkte analysierst.
Manchmal ist es nur ein einziger, den ptgui falsch platziert und der dann alles durcheinander bringt.
Es soll auch schon vorgekommen sein, dass Leute an ihr Stativ gerumpelt sind.
Die helle Deckenfläche ist ebenfalls ein möglicher Quell für Fehler.



Hallo Jürgen,

ich gehe immer (vom Bodenbild ausgehend) die restlichen Aufnahmen durch und ergänze die Kontrollpunkte per Auswahlrechteck. Dann lasse ich den Optimizer drüber laufen und dann noch 'Delete worst Controlpoints'. Zuletzt lösche ich manuell alle CPs die schlechter als 10 sind. Trotzdem die beschriebenen Stitchingfehler. Und mein Stativ behandele ich während der Aufnahme wie ein rohes Ei. Es muss also wirklich am Motiv liegen - sehr interessant, finde ich.

Gruß

Tom

kbaerwald

Super-User

Beiträge: 280

Wohnort: Ettlingen bei Karlsruhe

  • Nachricht senden

6

Sonntag, 13. Januar 2019, 14:49

Tom

das wird so nix mit der Rätselei - zippe deine Bilder und leg sie mit dem PTGui Projektfile auf einen Server. Dann kann man sie sich mal in Ruhe anschauen.

Gruß, Klaus

soulbrother

Mega-User

Beiträge: 907

Wohnort: München

Beruf: Werbefotograf

  • Nachricht senden

7

Sonntag, 13. Januar 2019, 16:14

Warum sollte es denn NICHT motivabhängig sein?

Wenn ich mal grob darüber machdenke, wie das Positionieren und Hinbiegen der Einzelbilder funktioniert, dann gibt es doch nur die beiden "herkömmlichen" Methoden:

A. Stichen nach fixen Templates - da sind die CP egal, da gar nicht genutzt.
oder
B. CPs werden im Motiv gesucht und danach wird hingebogen, bis es scheinbar passt

PTGUI 11 gegenüber 10 ist nicht nur in der GUI modernisiert, sondern insbesondere auch neue Parameter für präzisere, individuelle Anpassungen der unterschiedlichen Fisheye-Projektionen.
Dennoch dürfte es noch immer motivabhängige Unterschiede geben.

Tom58

Super-User

  • »Tom58« ist der Autor dieses Themas

Beiträge: 246

Wohnort: Südliches Rhein-Main-Gebiet

  • Nachricht senden

8

Sonntag, 13. Januar 2019, 17:25

Warum sollte es denn NICHT motivabhängig sein?

Wenn ich mal grob darüber machdenke, wie das Positionieren und Hinbiegen der Einzelbilder funktioniert, dann gibt es doch nur die beiden "herkömmlichen" Methoden:

A. Stichen nach fixen Templates - da sind die CP egal, da gar nicht genutzt.
oder
B. CPs werden im Motiv gesucht und danach wird hingebogen, bis es scheinbar passt

PTGUI 11 gegenüber 10 ist nicht nur in der GUI modernisiert, sondern insbesondere auch neue Parameter für präzisere, individuelle Anpassungen der unterschiedlichen Fisheye-Projektionen.
Dennoch dürfte es noch immer motivabhängige Unterschiede geben.


Danke, damit ist meine Frage vollumfänglich beantwortet! Mit der Version 11 liebäugle ich eh schon die ganze Zeit.

Gruß

Tom

9

Sonntag, 13. Januar 2019, 22:21

Zitat

Dann lasse ich den Optimizer drüber laufen und dann noch 'Delete worst Controlpoints'. Zuletzt lösche ich manuell alle CPs die schlechter als 10 sind. Trotzdem die beschriebenen Stitchingfehler. Und mein Stativ behandele ich während der Aufnahme wie ein rohes Ei. Es muss also wirklich am Motiv liegen - sehr interessant, finde ich.


Ich kann mich nicht erinnern daß ich jemals ein statisches Motive gehabt hätte, das ich nicht mit PTGUI fehlerfrei stitchen konnte, wenn keine Userfehler involviert waren.
Alles andere ist auch unlogisch.

Wie groß ist denn die mittlere Abweichung die du am Ende erhältst?
Sie sollte < 1 sein. Ist das nicht der Fall, hast du mindestens einen Fehler in deinem Ablauf.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Jürgen Schrader« (14. Januar 2019, 07:53)


Tom58

Super-User

  • »Tom58« ist der Autor dieses Themas

Beiträge: 246

Wohnort: Südliches Rhein-Main-Gebiet

  • Nachricht senden

10

Montag, 14. Januar 2019, 10:11

Zitat

Dann lasse ich den Optimizer drüber laufen und dann noch 'Delete worst Controlpoints'. Zuletzt lösche ich manuell alle CPs die schlechter als 10 sind. Trotzdem die beschriebenen Stitchingfehler. Und mein Stativ behandele ich während der Aufnahme wie ein rohes Ei. Es muss also wirklich am Motiv liegen - sehr interessant, finde ich.


Ich kann mich nicht erinnern daß ich jemals ein statisches Motive gehabt hätte, das ich nicht mit PTGUI fehlerfrei stitchen konnte, wenn keine Userfehler involviert waren.
Alles andere ist auch unlogisch.

Wie groß ist denn die mittlere Abweichung die du am Ende erhältst?
Sie sollte < 1 sein. Ist das nicht der Fall, hast du mindestens einen Fehler in deinem Ablauf.


Hallo Jürgen,

kleiner als 1 Pixel? Also praktisch 100% fehlerfrei? Dann mache ich wirklich sehr viele Fehler! Wie können wir meinen Fehlern systematisch auf den Grund gehen? Soll ich mal eine Bildreihe von 8 Fotos hier hoch laden und in welcher Auflösung? Oder umgekehrt und ich schaue mal, ob ich mit Deinen Bildern ebenfalls so ein tolles Stitchingergebnis erziele. Dann könnte man meine Fehler auf PTgui begrenzen. Kleiner als 1 Pixel? Ich bin echt sprachlos!

Danke und Gruß

Tom

kbaerwald

Super-User

Beiträge: 280

Wohnort: Ettlingen bei Karlsruhe

  • Nachricht senden

11

Montag, 14. Januar 2019, 10:58

PTGui benutzt ein statistisches Verfahren (Methode der kleinsten Fehlerquadrate) zur Berechnung des Fehlers bei der Optimierung. Der ist als Entfernung der jeweiligen CPs voneinander definiert. Alles, was kleiner ist als 5 kann als "ordentlich" bezeichnet werden (bitte, Abschnitt 5 durchlesen!).

Wichtig: wenn der Punkt der Eintrittspupille hinreichend genau bestimmt worden ist (Parallaxe o.k.) und keine Veränderungen der Teilaufnahmen durch Bildbearbeitung vorgenommen wurden (alle Aufnahmen mit identischen Belichtungswerten), sollten gegenüber der Kalibrierung keine Ausreisser der CPs vorkommen!

Grundsätzlich muss nicht jedes Kontrollpunkt-Paar mit einem hohen Wert auch fehlerhaft sein. Wenn man also alle hohen Werte in der CP-Tabelle händisch einfach so abschneidet und dann neu optimiert, muss das nicht zwangsweise zum Erfolg führen.

Tom58

Super-User

  • »Tom58« ist der Autor dieses Themas

Beiträge: 246

Wohnort: Südliches Rhein-Main-Gebiet

  • Nachricht senden

12

Montag, 14. Januar 2019, 11:26

PTGui benutzt ein statistisches Verfahren (Methode der kleinsten Fehlerquadrate) zur Berechnung des Fehlers bei der Optimierung. Der ist als Entfernung der jeweiligen CPs voneinander definiert. Alles, was kleiner ist als 5 kann als "ordentlich" bezeichnet werden (bitte, Abschnitt 5 durchlesen!).

Wichtig: wenn der Punkt der Eintrittspupille hinreichend genau bestimmt worden ist (Parallaxe o.k.) und keine Veränderungen der Teilaufnahmen durch Bildbearbeitung vorgenommen wurden (alle Aufnahmen mit identischen Belichtungswerten), sollten gegenüber der Kalibrierung keine Ausreisser der CPs vorkommen!

Grundsätzlich muss nicht jedes Kontrollpunkt-Paar mit einem hohen Wert auch fehlerhaft sein. Wenn man also alle hohen Werte in der CP-Tabelle händisch einfach so abschneidet und dann neu optimiert, muss das nicht zwangsweise zum Erfolg führen.


Hoch interessant! Nicht alle CPs mit hohen Zahlen sind also immer 100% fehlerhaft! Meine durchschnittliche Fehlerzahl ist so um die 3,5. Ich kann also davon ausgehen, dass mein NPA leidlich gut eingestellt ist. Warum kommt es dann beim beschriebenen (und beigefügten) Bild zu solchen Ausreißern? Kann dann tatsächlich nur an einer Konvusion bei PTgui durch die unterschiedlichen Abstände (Balken, Decke, Strukturen, etc.) liegen - oder? Dass es besser geht hat das System ja gezeigt.

Löst aber mein Problem nicht wirklich. Ich kann ja nicht immer hoffen, auf - für PTgui - möglichst passende Motive zu treffen. Wie sind denn Helligkeits- und Farbunterschiede in diesem Zusammenhang zu bewerten? Bei meinem 'fast fehlerfreien' Motiv ist alles etwa gleich hell und gleich farbig. Bei dem beigefügten Beispiel hingegen offensichtlich nicht.

13

Montag, 14. Januar 2019, 11:34

Das einfachste wird sein, du stellt die Bilder von deinem "Problembild" irgendwo zum Download bereit.
Größe 100% und JPG 60-80%, dann kann man das mal analysieren.

kbaerwald

Super-User

Beiträge: 280

Wohnort: Ettlingen bei Karlsruhe

  • Nachricht senden

14

Montag, 14. Januar 2019, 11:36

Wie hast du die Teilaufnahmen belichtet? Hast du vor dem Stitchen die Bilder bearbeitet?

Wie schon geschrieben - Original!!!-Bilder einstellen (unbearbeitet) und dann kann man ja mal sehen.

Gruß, Klaus

Tom58

Super-User

  • »Tom58« ist der Autor dieses Themas

Beiträge: 246

Wohnort: Südliches Rhein-Main-Gebiet

  • Nachricht senden

15

Montag, 14. Januar 2019, 18:06

Wie hast du die Teilaufnahmen belichtet? Hast du vor dem Stitchen die Bilder bearbeitet?

Wie schon geschrieben - Original!!!-Bilder einstellen (unbearbeitet) und dann kann man ja mal sehen.

Gruß, Klaus


Hallo Klaus,

die Originalbilder im RAW Format sind zu groß und außerdem sind genau diese Tonemapping Ergebnisse im Link immer meine Arbeitsgrundlage. Hat jetzt keinen Sinn mit den Originalbildern und einem anderen Tonemapping-Verfahren auf Fehlersuche zu gehen, dass ich nicht benutze. Also, das sind die Ausgangsbilder und hier gab es massive Stitchingfehler (trotz 0 Fehler Ergebnissen mit gleicher Hard- und Software bei anderen Motiven). https://photos.app.goo.gl/PSbvZxh8y9g3oYZC7

Jetzt bin ich mal gespannt, was ich falsch gemacht habe.

Danke vorab!

VG Tom

16

Montag, 14. Januar 2019, 18:58

Also mein bestes Ergebnis ohne Aufwand in PTGUI 10 und 11 liegt bei knapp 2,3.
Den Nadir habe ich jetzt mal weg gelassen, das spielt hier keine Rolle.

Damit erhalte ich ein Bild ohne erkennbare Stitchingfehler.

Wie gesagt geht es auch besser, wenn alles paßt.

Der Fehler kann in allem möglichen liegen, von ungenauer Justage am Kopf, biegsamen Bodendielen, wackeln beim Drehen, falschen Parametern (Objektiv, Optimizer, ...), u.s.w.
Alles schon da gewesen.

soulbrother

Mega-User

Beiträge: 907

Wohnort: München

Beruf: Werbefotograf

  • Nachricht senden

17

Montag, 14. Januar 2019, 19:25

Also mein bestes Ergebnis ohne Aufwand in PTGUI 10 und 11 liegt bei knapp 2,3.
Den Nadir habe ich jetzt mal weg gelassen, das spielt hier keine Rolle.

Damit erhalte ich ein Bild ohne erkennbare Stitchingfehler.

Auf die Werte komm ich auch, wenn ich die paar die darüber sind lösche ;-)

Aber Stichfehler an dem nahen Stuhl sind mehr als deutlich!
Weitere gibt es in wenigen anderen Bereichen noch (mit der Lupe) zu finden.

Mögliche Ursachen hat Jürgen schon aufgezählt, über sich biegende Dielen hab ich mich auch schon geärgert, wenn man es nicht gleich bemerkt beim Rumgehen im Kreis hinter der Kamera...

Hey, aber die passenden Exif Daten wären schon sinnvoll gewesen in den Bildern!

18

Montag, 14. Januar 2019, 20:40

Oops, kleiner faux pas :D
Obwohl ich dieses Bildpaar als das Schwächste ausgemacht hatte, habe ich mir die Stuhllehne nicht mehr genauer angeschaut ^^

Wenn das mein Setup wäre, würd ich jetzt ne eine Szene mit nem Betonboden bei unveränderten Einstellungen schießen und prüfen oder noch mal am NPP arbeiten.

kbaerwald

Super-User

Beiträge: 280

Wohnort: Ettlingen bei Karlsruhe

  • Nachricht senden

19

Montag, 14. Januar 2019, 21:31

Ebenso mein Einwand - es gibt starke Parallaxenprobleme im Bereich der Stuhllehnen, die anderen Abweichungen kann man ausgleichen. Da musst du nochmals nacharbeiten. Den Nadir habe ich erst garnicht probiert.

Gruß, Klaus

20

Montag, 14. Januar 2019, 22:37

In PTGui 10 und 11 mit etwas Aufwand <0,94 (Mit Nadir).

Die Probleme an der Stuhllehne und am Tisch lassen sich leicht maskieren.

Wenn ich mich nicht irre sind die Probleme der Vorgabe in erster Line:
- das Pano ist in sich „verdreht“ und schief. Die ganze Scheune steigt in Richtung rechts an. (Die Seite, auf der Sitzsack ist.)
- bei Bild 4 (Richtung Kommode mit dem Radio) stimmt etwas nicht. Wackelnde Diele?

Für eine DIY-Makleraufnahme aber sehr gut ;-)
Viele Erfolg damit.

Gruß
Wolf

Ähnliche Themen